FANDOM


Versions of MagicaVoxel and their update log.


0.99.6 - June 30th, 2020

  1. New Unified Material System
    • Blend Material: weighted blending Metal/Plastic/Glass/Cloud materials (similar to Disney Principled BRDF).
    • SSS Material: sub-surface scattering. transparency tp control light transmission. density to control light scattering.
    • Aborb/Scatter/Emissive Media Material: emissive cloud. can be contained in the glass with ior > 1.
    • Improved Alpha Blending: glass material, absorb media type, density = 0, ior = 0, transparency > 0



0.99.5.1 - June 5th, 2020

  1. World Editor
  2. Brush
    • brush modes (V/F/B/L/C/P) and options (Mirror/Axis) can be applied to the brush selection tool
    • new resizable box brushe use gizmo to resize the box; ENTER or other stroke/edit to commit
    • new SDF brush: box brush + voxel shader
    • CTRL + ALT + drag to resize voxel brush
    • sculpt brushes can be applied to either selected or unselected regions
    • Region options are also applied to remove/replace voxel color brushes
  3. Live crop and fit
    • Fit tool allows fitting the size of multiple objects
    • Crop tool allows live resizing the canvas: drag arrow body to resize, drag arrow head to move
    • New 1/2 tool
  4. IO panel
    • export / import palette / materials / rendering / camera / notes settings in text format
    • determine which components are saved in the vox file
    • export options: only export selected objects; export models in local space
    • import options: match similar colors in the palette; only import colors/materials for selected palette region
  5. Shader panel
    • can bind user defined arguments to the interface via comments
    • live update by using the box brush
  6. Palette Note panel
    • add note to each row of the palette
  7. Display
    • Ambient Occlusion (AO) and Constant shading modes
    • Fade: Toggle background objects fading
    • change grid/edge/selection/background color



0.99.5.0.2 - May 13th, 2020

  1. Scene editor
    • Double-click to enter/leave objects.
    • Right-double-click to leave objects.
    • Constant shading modes.
    • The latency of switching between model editor and scene editor is reduced.



0.99.5.0.1 - May 4th, 2020

  1. Multiple Color Selection in the Palette
    • the color and material modification (and some other cmds) can be applied to multiple colors now.
    • e.g., rand cmd now uses the multiple selection as random range.
    • click : single cursor selection;
    • drag : multiple selection;
    • shift + drag : add selection;
    • shift + alt + drag : remove selection;
    • can copy and paste color code from the RButton menu.
    • can select voxels by colors from the RButton menu.
    • can select colors by voxels from the RButton menu.
  2. Brush Selection
    • Brush modes (V/F/B/L/C/P) and options (Mirror/Axis) can be applied to the brush selection tool.
    • Brushes can be applied to either selected or unselected voxels.



0.99.5 - April 5th, 2020

  1. Refactored Interface
    • Canvas size for single object increases to 256x256x256vx.
    • Rendering method in the editor view is changed to pure ray casting.
    • Most of the brushes and edit commands are shader-based now (GPU accelerated).
    • Undo/Redo commands are compressed to reduce memory usage. (can undo up to 100 commands)
    • Can import jpeg images and export jpeg screenshot.
  2. Config.txt
    • workspace: new dir_ibl and dir_plugin settings
    • view: removed ground_color, edge_color, bg_color, bg_fade
    • New model_editor setting to choose computing between cpu and gpu



0.99.4.2 - September 8th, 2019

  1. Intel Open Image Denoiser
    • Requirement: Windows x64, 4GB memory
    • Installation: download plugin-win64.zip and extract the content to your MagicaVoxel folder.
    • Image->Filter->Denoise: denoise rendered images in the preview mode. use mouse wheel to zoom in/out, left-drag to move image.
    • Image->MRT: render additional albedo and normal images to help the denoiser to preserve details. note that it does not always improve the quality.
    • Sample->Bounce->Clamp: clamp energy to reduce noises.


0.99.4.1 - September 1st, 2019

  1. Renderer
    • Sky->IBL: Image Based Lighting. use ".hdr" format panorama images to light the scene.
    • Fog: add Equi-angular sampling back to reduce noises. support fogs in othogonal views in a bounding volume.
    • Media: enable Sample->TR-Shadow to allow single direct lighting; enable Sample->MIS-Cloud to allow multiple direct lighting (very expensive).
    • Color all color options have their own color pickers which support HSV, RGB, H-Block and Hex values.
    • Palette Menu right click the palette view to show the pop-up menu.


0.99.4 - May 29th, 2019

  1. Renderer
    • Matter->Cloud: Media material which supports multiple scattering inside volume.
    • Sample->MIS-GGX: Multiple Importance Sampling (MIS) for GGX surfaces (Metal/Plastic/Glass) for better reflection.
    • Sample->TR-Shadow: Tranlsucent Shadow which allows light passing though glass and cloud voxels. Only Glass->Attenuation can affect the light color.
    • can adjust Bounce->Diffuse/Specular/Scatter path depths separately.
    • can assign glass/cloud materials to sphere/cylinder shape voxels (for experiments only).
    • the renderer pipeline is refactored, which needs more time to improve, optimize and fix bugs.
    • some features such as fog scattering requires more researches.
    • frame drops and noises are expected.


0.99.3 - February 3rd, 2019

  1. Final Image Render : Render->Image Settings (Right Panel)
    • Photo Mode: up to 12000 x 12000 size images. Bloom effect is not available.
    • Turntable Mode: spinning camera animation with Motion Blur. Saved as name (frame index).png image sequence.
    • Both modes can render in the background.
    • You may need to disable vsyn in the GPU panel for this program.
  2. Lens
    • Panorama Projection: Lens->Pano. Set image size width = height x 2
    • Focus: can fix or set focus distance by numbers.
    • Depth of Field effect can be enabled in all camera projection modes.
    • Fixed bugs for camera blades (images become darker) and grids.
  3. Camera Control
    • X+left click to set the camera rotation center in both editing and rendering modes.
  4. Export
    • add slices/cubes/point clouds export options
    • export settings (scale, axis, etc.) can be found in config/config.txt/io_*
    • export objects are named as [project name]-[index]-[object name].[ext]
    • the vertices of the mesh exports are using their global positions in the world editor.
  5. Config
    • can modify edge/ground/background/fade color of the editor
    • add hotkey.txt in config/ folder to bind keys to commands.
    • the keys A-Z, 0-9, F1-F12 are recommended.
    • repeat token means that you can hold the keys to automatically perform multiple times of actions, e.g. undo/redo
    • commands may be refactored in the future. The feature is not robust. Use it carefully.


0.99.2 - September 29th, 2018

  1. New Interface
    • Redesigned the interface
    • Slidable and resizable panels
    • SDF font rendering
    • CTRL+Wheel or CTRL +/- to scale UI size
    • a basic object list to show the scene graph, will be improved in future updates
  2. Renderer
    • Large Sparse Volume: Sample->Geometry->SV the rendering volume increases to 2048x2048x1024. But the total number of solid voxels is still limited. SV Mode works with cubic voxel only
    • Voxel Shapes: new Clay shape with the previous supported shapes (Lego, Marching Cubes, etc.)
    • World Scale: rectangular voxels
    • Pixelated Illumination: Sample->PX
    • Can show sun disk in the sky; added Ozone attenuation
    • Fix bugs in orthogonal views
    • Voxel shapes and SV mode will be improved in future updates
  3. Palette
    • CTRL+Drag: swap (move) color
    • CTRL+SHIFT+Drag: duplicate color
    • cmd pal sort [+-hsvrgb]: sort palette colors (e.g. pal sort vsh)
  4. Voxel Shader
    • add xs_shader in config.txt
    • can execute subfolder shaders: xs sub/poly


0.99.1 - March 12th, 2018

  1. Renderer (hidden menu)
    • Atmospheric Scattering Skydome: Rayleigh/Mie scattering
    • Bladed Bokeh: for large depth of field
    • Stretched Bloom Filter
    • Grids: can change Spacing, Width, and Color
    • Field of View (FOV): change range to: 1-360
    • Fix some bugs: e.g. Bloom dark points
    • More options are saved into file, format is changed as well
  2. Editor
    • Align Objects in Editor
    • New object is using last model size
    • Fix importing files with unicode paths
    • Add default export and snapshots folders in config


0.99 - November 23th, 2017

  1. World editor
    • Support multiple objects
    • Larger scene area: (-1024, +1024)
    • Group objects
    • Reference objects/groups: modifying one of the references will affect the others
    • Transform objects: rotate, flip, move
    • Rectangle select: SHIFT to add selection, ALT+SHIFT to remove selection
    • Translation gizmo and free movement: Shift+move to get a referenced copy
    • Union combine objects
    • Copy/paste objects between world editor and model editor
    • Hide objects
    • Change order of objects for drawing and combination
    • Layers: to hide objects with same layer tag
    • Hotkey TAB to switch between model editor and world editor
    • Hotkey TAB/SHIFT+TAB to enter/leave groups
  2. Renderer
    • Performance optimizations
    • Support larger volumes: 512x512x512, 1024x512x256 or 1024x1024x128
    • Can copy/paste materials using CTRL+C/V or Matter->C/P
    • Rendering settings are saved into file: lighting, lens, ground/edge colors, etc.
    • Blooming effect is automaticlly calculated, and can be paused as well
    • Can display constant color background: View->Back
  3. View Cube
    • Smooth camera transition
    • Click the cube face/edge/vertex to set to 26 standard view angles (90/45)
    • Left-drag the view cube to rotate view
    • Hotkey 4 to recenter view; hotkey 5 to show one of the 6 face views (front, back, etc.)
    • Z+left drag to zoom view
    • X+left drag to rotate view
    • Space+left drag to move view
    • 7/8 to save/load view
  4. Editing
    • Auto-saved to cache/ folder every 25 steps
  5. UI
    • UI scaling for High DPI screens: enter ui scale 1.5 in console or change ui_scale in config.txt
    • Panel is scalable (some UI elements are hidden behind)
    • Palette: pick color from screen: ALT+left drag
    • Lower CPU usage: only redraw when needed
  6. Limitations: will be improved in future version
    • Not stable
    • Export: can only export single models, cannot export models with offsets and names
    • Render: no voxel shapes
    • Animation: no frame based animation


0.98.2 - April 1st, 2017

  1. Bloom
    • Click the button in Bloom section to calculate bloom effect when any rendeirng setting has been changed
    • It has its own progress bar, and uses the same number of samples from the top
    • When adjusting the weight with the slider, it won't restart rendering
    • It will enable Camera->ACES automatically
  2. Bokeh
    • It has larger aperture size for DOF (depth of field)
  3. HDR Emissive Material
    • Formula is changed to Emit * (10 ^ Power)
    • Glow is only used to enhance Bloom and Bokeh effects
  4. Pause Rendering and Instant Feedback
    • Click Image->|| to pause progressive rendering
    • Enable Sample->GI
    • Every change of material will be immediately displayed in viewport
    • (*expensive option, higher end GPU recommended)
  5. Sky Background
    • Enable View->Back (CTRL+B) to display sky as background
    • The fading ground into horizon is controled by Fog slider
    • For real fog, enable Fog firstly
  6. Ground Material
    • Now you can use Alt+LButton to click the ground, and then assign Metal material to it
  7. Pixelated Rendering
    • Turn off View->AA to disable Anti-Aliasing and set image size small (128, e.g.)


0.98.1 - December 30th, 2016

  1. Selection
    • New Box/Rect/Region selection brushes
    • New selection tools Edit->Select: Copy/Paste, Deselect/Inverse Select, etc.
    • Attach/Erase/Paint brushes can only operate on unselected voxels
    • Move/Remove Color/Replace Color brushes can operate on both selected and unselected voxels
    • Edit Tools can only operate on selected voxels
    • Transform Tools Flip/Rot/Loop/Scale/Repeat modify selected voxels around local center
    • Export only exports selected voxels if selection exists
  2. Selection Brushes
    • +SHIFT to add selection, +SHIFT+ALT to subtract selection
    • Box Select: select voxels within a box
    • Rect Select: select voxels within a screen rect: K+RButton click voxel to navigate to 90 degree view
    • Region Select: select voxels within same volume, same face, or with same color
  3. Pattern Brush
    • Can create Pattern directly from selection: very helpful for texturing surface/duplicating small shapes
    • Can rotate Pattern around z, x, y axes with keys -/+, 9, 0
    • Can add local offset to Pattern with arrow and page keys
    • Reset local offset to 0 with Home key
  4. Bounding Box and Frame Grids
    • Can select on all six faces of bounding box now
    • View->Frame: can change spacing, very helpful for measurement
  5. Camera Setting
    • Camera->ton: ACES Filmic Tone Mapping
    • Camera->dof: Depth of Field, click voxel with LButton to set camera focus
  6. Misc
    • Command dia [axis]: diagonal symmetry
    • Command o slice: export volume as an image of size (width, height x depth)


0.98 - October 22th, 2016

  1. Frame-Based Animation
    • Supports up to 24 frames animation
    • Ctrl+Drag to move frame, Ctrl+Shift+Drag to duplicate frame
    • Press on the prev/next button to play animation (you can also change time step)
    • Drag and drop multiple models to import as animation
    • It can also be used for other purposes, like assets of same category
    • However, features of importing and exporting anim are not fully supported yet
  2. New Interface
    • Materials are saved into .vox file now
    • If there are unsaved changes, the tiny button besides name field will become orange, click it to save
    • Program will ask for saving changes when opening new models or closing the program
    • Click the title of each panel to close it
    • Tool->Scale, Repeat, Rotate are removed, use console commands scale, repeat, rot instead
  3. Voxel Shader also supports generating anim now
    • [New inputs]
    • iFrame: current frame index
    • iNumFrames: total num of frames
    • iIter: current iteration index
    • iRand: a vec4 random number updated every iter and frame
    • [New Options]
    • -n: specify number of iterations, eg. xs -n 8 [shaderName]
    • -prev/-cur: specify input frame, -prev for previous frame, -cur for current frame (default is -prev)

0.97.5 - 09/25/2016

  1. Fog Scattering: can scatter all types of lights (Sun/Sky/Area)
    • Only works in Pers/Free camera modes
    • Works for glass/metal materials (can get reflection/refraction from sun light)
    • Surface can also be lit by scattered light
    • Can create light shafts
    • Can create background with small fog density
    • Fog color mainly depends on light color and in-scattering color
  2. Ground is changed to infinity large in all camera modes
  3. Optimized shaders by removing unused branches

0.97.4 - 07/05/2016

  1. New Emissive Area Lighting
    • Emit->Power: Radiant Flux for Area Lighting
    • Emit->Glow: Energy loss on closer surface
    • Emit->Total: Total power for all voxels or power density
  2. Hints:
    • Requires GI option enabled for advanced effects
    • Only supports Cubic/RG/RE voxel shape
    • For small but strong light source (e.g. point lights), use Emit->Total
    • It is recommended to use lower image resolution (e.g. 640x480) when adjusting parameters
    • For better quality of final image, use more samples (e.g. 5000)
    • Not very robust for this version (has several potential artifacts)
    • If it is still too dark, do not forget to use Post->E to increase exposure
  3. Fix several artifacts for Glass material

0.97.3 - 06/05/2016

  1. New Metal/Plastic Material with GGX NDF
  2. Post Effects
    • Post->E: Exposure, when the scene is too dark, you can increase this
    • Post->V: Vignette
    • Camera->G: Gamma Correction
  3. Pick up Sun/Sky Color from Palette
  4. Better Quality of Soft Shadow
  5. Sample->GI : on the top right, enable stochastic sampling for better indirect illumination
    • It's slower (~50%) and noisy (requires 3000+ samples)
    • Use it for indoor scenes, larger exposure, or final render

0.97.2 - 03/02/2016

  • Export->bake: bake voxel mesh with ambient occlusion and soft shadow:
    • Example on Sketchfab
    • Must support the built-in renderer, if program crashed, recover model from cache/ directory
    • It may take from several seconds to half a minute, depending on machine, model, and sample number
    • Set sample number, direction and intensity of light sources in renderer mode
    • config->bake->perface: bake per face (pixelated) or per vertex (smooth)
    • config->bake->ambient: constant ambient color to make scene brighter
    • config->bake->gamma: for app with gamma correction, set it to 2.2 to avoid color washed out
  • New CMD odir: export all models in current folder, e.g. odir obj
  • Palette ALT+DRAG: swap palette color without changing model, make it easier to organize palette
  • Fixed a bug in .qb export

0.97.1 - 02/15/2016

  1. New Voxel Shader:
    • Supports GLSL based shader script to generate your custom volume
    • Shaders are in the new folder shader/
    • Try typing [xs wave] in console to start
    • Basic command format is: xs [shader name] [arg0] [arg1] [..]
    • If you want to run the shader multiple times in one run, use: xs [num] [shader name ] [args...]
  2. New Brush Options:
    • [V]oxel Mode: 3D (Volume: Cube, Sphere), 2D (Flat: Square, Disc), Su (Surface, only operates on surface)
    • - Added hotkeys 1-9 to set brush size quickly
    • [C]enter Mode: supports both square and circle shape now
    • [P]attern Mode: can choose using either original model color or current palette color
    • - Can be applied on erasing and painting now
  3. New Marching Cube Export Export->mc: export your voxel model as Marching Cube meshes (.ply)
  4. Camera Control: use middle button to move camera
  5. Cache Folder cache/: program will automatically backup model before quitting program or rendering model
  6. Obj Export Pivot: fixed bugs for obj pivot, you can also set your custom pivot in config.txt->file_obj
  7. Palette Command: added command pal mask to mask out unused color in palette
  8. Fixed a little rendering bug with orth/iso camera, still not very robust though

0.97 - 11/30/2015

  1. Enhanced Brushes, Improved UI and File System:
  • Save and Open dialog for all Palette, Model, Export, Screenshot files
  • Face Brush: extrude surface by dragging with various modes
  • Voxel Brush: has been integrated with Cube and Sphere Brushes, working with mirror and axis modes now
  • Circle Brush: center voxel of circle is not operated; support even diameter size
  • HUD: voxel coordinates, volume size, face layers, circle radius are displayed in console now
  • Camera: added X+RButton to select camera focus center, and yellow button to toggle auto camera focus
  • Export: fixed obj export and more config options for isometric and 2d sprite export
  • Render: Light->0 is changed to pure color model; the ground in orth/iso mode will be infinity large
  • Multiple UI improvements

0.96.3 - 08/15/2015

  1. Matter->Glass: new transparent voxels with refraction and attenuation

0.96.2 - 08/09/2015

  1. Matter->Sel: per palette material setting (use Alt+LButton or LButton to select material)
  2. New Emissive material; perfect mirror reflection (Rough = 0); over 8 light bounces
  3. Folder path setting in config file; bug fixed for .obj export

0.96.1 - 07/05/2015

  1. Export->iso: new isometric sprites export
  2. Export->obj: color based mesh simplification for .obj format
  3. Model List: drag 'n drop folder to model list to change its root path

0.96 - 05/24/2015

  1. Renderer supports various voxel shapes (Lego, Marching Cube, Sphere, Cylinder) and rounded corners, colored grids
  2. Camera supports stereographics projection, radial distortion, Escher Droste effect
  3. Use F5/F7 to save/load current camera
  4. Performance improvement and bug fixes



Source
Update log of official website.

Community content is available under CC-BY-SA unless otherwise noted.